Параметры разрешений для конкретного приложения не предоставляют локальную активацию
Если в средстве просмотра событий отображается сообщение об ошибке Параметры разрешений для конкретного приложения не предоставляют разрешение на локальную активацию для приложения COM-сервера., тогда эта статья вам поможет. Он поставляется с Идентификатор события DCOM 10016, и эта ошибка появляется в основном после обновления операционной системы. Хотя эта ошибка не влияет на работу обычного пользователя Windows 10, некоторые из вас могут захотеть узнать, почему это происходит и что вы можете с этим сделать.
Эти 10016 событий записываются, когда компоненты Microsoft пытаются получить доступ к компонентам DCOM без необходимых разрешений. Эти события обычно можно безопасно игнорировать, потому что они не влияют отрицательно на функциональность и являются преднамеренными.
Все сообщение об ошибке выглядит так:
Параметры разрешений для конкретного приложения не предоставляют разрешение локальной активации для приложения COM-сервера с CLSID
и APPID <316CDED5-E4AE-4B15-9113-7055D84DCC97>пользователю NT AUTHORITY LOCAL SERVICE SID (S-1-5-19) с адреса LocalHost (с использованием LRPC), запущенного в контейнере приложения. Недоступный SID (недоступен). Это разрешение безопасности можно изменить с помощью инструмента администрирования служб компонентов.
Для вашего сведения, CLSID и APPID могут отличаться на вашем компьютере, поскольку они представляют собой компонентную службу на вашем компьютере. Что касается решения, оно уже упоминается в сообщении об ошибке. Вам необходимо изменить разрешение безопасности с помощью инструмента администрирования в Windows 10.
Параметры разрешений для конкретного приложения не предоставляют локальную активацию
Чтобы исправить настройки разрешений для конкретного приложения не выдают ошибку локальной активации в Windows 10, выполните следующие действия:
- Определите и подтвердите CLSID и APPID
- Измените владельца ключа CLSID из редактора реестра
- Изменить разрешение безопасности из служб компонентов
Прочтите, чтобы узнать подробности о шагах.
Вам необходимо определить CLSID и APPID. Поскольку на вашем компьютере они могут быть разными, очень важно их распознать. В противном случае вы не сможете избавиться от этого сообщения об ошибке средства просмотра событий. Согласно вышеупомянутому сообщению об ошибке, CLSID —
Теперь вам нужно найти компонент, который создает проблему. Для этого откройте редактор реестра на своем компьютере. Для этого нажмите Win + R, введите regeditи кнопку Enter. После этого перейдите по этому пути —
Не забудьте заменить Введите ваш-ClSID с исходным CLSID, который вы получили в сообщении об ошибке. Получив его, вы должны найти APPID справа. Убедитесь, что этот APPID и предыдущий APPID (упомянутый в сообщении об ошибке) совпадают. После подтверждения щелкните правой кнопкой мыши CLSID слева и выберите Разрешения вариант.

Затем щелкните значок Передовой кнопка.
По умолчанию этот ключ принадлежит TrustedInstaller, но вам нужно изменить владельца на администратора. Для этого нажмите кнопку Изменять кнопка в Расширенные настройки безопасности окно> напишите «Администратор»> щелкните Проверить имена кнопку> щелкните Ok кнопка.
Также вам нужно выбрать Заменить владельца подконтейнеров и объектов флажок.
После этого выберите Администраторы от Группы или имена пользователей список и отметьте Разрешить / Полный доступ флажок. Теперь сохраните ваши настройки.

Также вам необходимо проверить По умолчанию — Данные имя. В этом примере имя данных по умолчанию — Иммерсивная оболочка. Он должен быть другим, если в вашем сообщении об ошибке используются разные идентификаторы CLSID и APPID.
После этого вам также необходимо стать владельцем APPID. Для этого перейдите по этому пути в редакторе реестра —
Вам нужно сделать то же самое, что и выше, чтобы изменить владельца этого ключа реестра.
Если у вас возникла проблема с изменением владельца ключа реестра, вы можете воспользоваться нашим бесплатным инструментом RegOwnit, который позволяет сделать это одним щелчком мыши.
Если вы выполнили эти шаги, вам нужно открыть Компонентные услуги. Вы можете найти его в поле поиска на панели задач и щелкнуть соответствующий результат. После открытия Component Services перейдите сюда —
В этом примере CLSID совпадает с этой службой компонента Immersive Shell. Вам нужно найти По умолчанию — Данные имя, полученное вами в редакторе реестра. После распознавания щелкните правой кнопкой мыши компонентную службу и выберите Характеристики. Здесь вы должны найти ID приложения или же APPID что вы можете подтвердить еще раз.

Далее перейдите к Безопасность таб. Здесь можно найти три метки, в том числе Разрешения на запуск и активацию. Щелкните соответствующий Редактировать кнопка.
Если вы получили какое-либо предупреждающее сообщение, щелкните значок Отмена кнопку и вперед. Вам нужно выполнить те же шаги, что и выше, чтобы добавить две учетные записи —
После добавления выбирайте по одному и дайте Локальный запуск и Локальная активация разрешения для них обоих.
Сохраните изменения, вы больше не получите ту же проблему в средстве просмотра событий.
Независимо от того, возникла ли у вас проблема с RuntimeBroker, Immersive Shell или любым другим процессом, решение будет одинаковым для всех.
Localhost с использованием lrpc что это

Доброго времени суток, уважаемые читатели, сегодня решаем ошибку 10016 параметры разрешений для конкретного приложения не дают разрешения Локально Активация для приложения COM-сервера с CLSID
Ошибка 10016 в windows 10 и Windows Server
На сервере Windows Server 2012 R2 постоянно возникает ошибка 10016.
Параметры разрешений для конкретного приложения не дают разрешения Локально Активация для приложения COM-сервера с CLSID
и APPID
<9CA88EE3-ACB7-47C8-AFC4-AB702511C276>или <316CDED5-E4AE-4B15-9113-7055D84DCC97>или <4839DDB7-58C2-48F5-8283-E1D1807D0D7D>
пользователю NT AUTHORITY\СИСТЕМА с ИД безопасности (S-1-5-18) и адресом LocalHost (с использованием LRPC), выполняемого в контейнере приложения Недоступно с ИД безопасности (Недоступно). Это разрешение безопасности можно изменить с помощью средства администрирования служб компонентов.

Данная ошибка выскакивает, когда какая-то из утилит не может обратиться к DCOM объекту, чаще всего, это связано с недостаточностью разрешений. Был реализован шаблон кодирования, где код сначала пытается получить доступ к компонентам DCOM с одним набором параметров. Если первая попытка не удалась, она пытается снова с другим набором параметров. Причина, по которой он не пропускает первую попытку, заключается в том, что существуют сценарии, в которых он может быть успешным. В этих сценариях это предпочтительнее. Если вы не в курсе, что такое COM объекты и DCOM, то если по простому, это концепция для создания программного обеспечения на основе взаимодействующих компонентов объекта, каждый из которых может использоваться во многих программах одновременно. На основе COM были созданы ActiveX, DCOM, COM+, DirectX, .Net.
- <316CDED5-E4AE-4B15-9113-7055D84DCC97>— Кнопка пуск (Immersive Shell) — интерфейс метро
- <4839DDB7-58C2-48F5-8283-E1D1807D0D7D>— ShellServiceHost
- <9CA88EE3-ACB7-47C8-AFC4-AB702511C276>— RuntimeBroker
Методы решения ошибки 10016
Сначала нужно обновить Windows через центр обновления, и если не поможет, то делаем по очереди предложенные решения:
- Назначаем недостающие права на ветку с GUID номером <9CA88EE3-ACB7-47C8-AFC4-AB702511C276>или другим, зависит от вашей ситуации с кодом ошибки 10016
- Удаление некоторых ключей реестра
- Использование скрипта PowerShell
Как исправить ошибку 10016 через назначение прав в реестре
- Сразу логинимся на проблемный сервер под администратором, чтобы не вводить всякий раз имя и пароль. Запускаем Regedit.
- Запускаем поиск (CTRL+F) и ищем второй из GUIDов в описании ошибки, т.е. APPID. В данном случае это «<9CA88EE3-ACB7-47C8-AFC4-AB702511C276>».

- Первый результат поиска должен быть в ключе HKEY_CLASSES_ROOT\AppID\. Наступаем на найденный GUID в левой панели и щелкаем правой кнопкой, выбираем Разрешения, а затем кнопку Дополнительно.

- В верхней части дополнительных параметров указан текущий владелец TrustedInstaller. Нажимаем рядом с ним ссылку Изменить.

- Нам нужно сделать владельцем локальную группу Администраторы. Затем кнопки Дополнительно, Поиск и выбираем в результатах поиска Администраторы.

- Ставим флажок «Заменить владельца подконтейнеров и объектов», кнопка ОК.

- После смены владельца мы можем изменять разрешения. В окне Разрешения на вкладке Безопасность даем для СИСТЕМА и Администраторы разрешение на полный доступ. ОК.
- Далее смотрим для нашего ключа HKEY_CLASSES_ROOT\AppID\ <9CA88EE3-ACB7-47C8-AFC4-AB702511C276>значение параметра «(По умолчанию)» = «RuntimeBroker«.

8. В диспетчере серверов в правом верхнем углу меню Средства -> Службы компонентов. Открываем Компьютеры –> Мой компьютер –> Настройка DCOM. Правый клик по строке из п.7 RuntimeBroker, Свойства.

9. На вкладке Безопасность. В разделе Разрешения на запуск и активацию кнопка Изменить. Для группы СИСТЕМА разрешаем Локальный запуск и Локальная активация. ОК. Если вам runtimebroker не дает отредактировать настройки, то вам нужно дать права на него в реестре Windows

щелкаем по нему правым кликом и выбираем свойства.

Даем права для группы администраторы (Полный доступ)

Если не даст вам поставить, то вам нужно заменить владельца Trustinstaller на себя или группу администраторы. Как только дали права, идем опять в компоненты DCOM и выставляем права, как описывал выше.

10. Перезагружаем сервер, проверяем логи, по сути ошибку 10016 параметры разрешений для конкретного приложения не дают разрешения Локально Активация для приложения COM-сервера с CLSID
Как исправить ошибку 10016 через удаление ключей из ветки OLe
Данный метод подразумевает удаление нескольких ключей реестра, которые отвечают за проверку прав на COM объекты. Нас будет интересовать ветка реестра:
Ole — эта ветка управляют параметрами запуска по умолчанию и разрешениями доступа, а также возможностями безопасности на уровне вызовов для приложений на основе COM, которые не вызывают CoInitializeSecurity. Только администраторы, создатель объекта и система имеют полный доступ к этой части реестра. Все остальные пользователи имеют доступ только для чтения.
Щелкаем по контейнеру Ole правым кликом и из контекстного меню выберите пункт Экспорт.

Задаем имя экспортируемого ключа. В случае проблем вы всегда сможете его импортировать и вернуть все к исходному состоянию.

Теперь, чтобы исправить ошибку 10016 в Windows 10 или как у меня в Windows Server 2012 R2 или выше, вам необходимо удалить четыре ключа:
- DefaultAccessPermission — Определяет список разрешений доступа по умолчанию для компьютера. Устанавливает список контроля доступа (ACL) участников, которые могут получить доступ к классам, для которых нет настройки AccessPermission . Этот ACL используется только приложениями, которые не вызывают CoInitializeSecurity и не имеют значения AccessPermission под своим ключом AppID. Среда выполнения COM на сервере проверяет ACL, описываемый этим значением, при олицетворении вызывающей стороны, которая пытается подключиться к объекту, и ее успех определяет, разрешен или запрещен доступ. Если проверка доступа не пройдена, соединение с объектом будет запрещено. Если это именованное значение не существует, только серверу участника и локальной системе разрешается вызывать сервер. По умолчанию это значение не содержит записей. Только принципал сервера и система могут вызывать сервер. Это значение обеспечивает простой уровень централизованного администрирования доступа по умолчанию к подключенным объектам на компьютере.
- DefaultLaunchPermission — Определяет список запуска по умолчанию для компьютера. Определяет список контроля доступа (ACL) участников, которые могут запускать классы, которые не указывают свой собственный ACL через значение реестра LaunchPermission. Права доступа по умолчанию следующие: Администраторы: разрешить запуск, СИСТЕМА: разрешить запуск, ИНТЕРАКТИВНО: разрешить запуск. Если значение LaunchPermission установлено для сервера, оно имеет приоритет над значением DefaultLaunchPermission . После получения локального или удаленного запроса на запуск сервера, у которого ключ AppID не имеет собственного значения LaunchPermission, проверяется ACL, описанный этим значением, при олицетворении клиента, и его успех разрешает или запрещает запуск кода класса.Это значение обеспечивает простой уровень централизованного администрирования запуска по умолчанию для доступа к другим незарегистрированным классам на компьютере. Например, администратор может использовать инструмент DCOMCNFG для настройки системы, чтобы разрешить доступ только для чтения для опытных пользователей. Поэтому OLE будет ограничивать запросы на запуск кода класса членами группы «Опытные пользователи». Впоследствии администратор может настроить разрешения на запуск для отдельных классов, чтобы предоставить возможность запуска кода класса другим группам или отдельным пользователям по мере необходимости.
- MachineAccessRestriction — Устанавливает политику ограничения на уровне компьютера для доступа к компоненту. Принципалы, которым здесь не предоставлены разрешения, не могут получить их, даже если разрешения предоставляются значением реестра DefaultAccessPermission или функцией CoInitializeSecurity. По умолчанию члены группы «Все» могут получать разрешения на локальный и удаленный доступ, а анонимные пользователи могут получать разрешения на локальный доступ.
- MachineLaunchRestriction — Устанавливает политику ограничения на уровне компьютера для запуска и активации компонента. Принципалы, которым здесь не предоставлены разрешения, не могут получить их, даже если разрешения предоставляются значением реестра DefaultAccessPermission или функцией CoInitializeSecurity. По умолчанию администраторы могут получать разрешения на локальный и удаленный запуск и активацию, а члены группы «Все» могут получать разрешения на локальную активацию и запуск.
теперь находим все эти ключи, щелкаем по ним правым кликом мыши и удаляем со спокойной душей, далее я вам советую перезагрузить вашу систему. В подавляющем количестве случаев ошибка с кодом 10016 у вас больше не появится.

Исправление ошибки 10016 через PowerShell
Если вам не удалось изменить запуск службы для системы, то можно все поправить и избавиться от сообщений «APPID
<9CA88EE3-ACB7-47C8-AFC4-AB702511C276>
пользователю NT AUTHORITY\СИСТЕМА с ИД безопасности (S-1-5-18) и адресом LocalHost (с использованием LRPC), выполняемого в контейнере приложения Недоступно с ИД безопасности (Недоступно)» с помощью скрипта PowerShell. Открываем ссылку с Microsoft
Скачиваем тут сценарий DCOMPermissions.psm1

Кладем данный модуль в нужную вам папку. Далее вы открываете консоль PowerShell и переходите в месторасположение данного модуля, после чего его нужно импортировать:
Grant-DCOMPermission -ApplicationID «<9CA88EE3-ACB7-47C8-AFC4-AB702511C276>» -Account «SYSTEM» -Type Launch -Permissions LocalLaunch,LocalActivation -OverrideConfigurationPermissions
Если ошибок не вышло, то значит все успешно применено, перезагрузка не потребуется.
Ошибка DistributedCOM 10016 в Windows: Параметры разрешений для приложения не дают разрешения локальной активации
11.02.2019
itpro
Windows 10, Windows 7, Windows Server 2012 R2
комментариев 19
В этой заметке я покажу, как исправить ошибку c Event ID 10016 от источника DistributedCOM на компьютере с Windows 10 / Windows Server 2012 R2. Ошибка DCOM 10016 довольно часто встречается как в клиентских, так и в серверных версиях Windows, начиная еще со времен Windows XP и исправляется она одинаково, независимо от редакции Windows.
Проблема проявляется следующим образом: в журнале событий системы при загрузке компьютера или попытке запуска/установки приложения появляется следующая ошибка:
Log Name: Система

В англоязычных версиях Windows описание ошибки такое:
The machine-default permission settings do not grant Local Activation permission for the COM Server application with CLSID
<000209FF-0000-0000-C000-000000000046>and APPID Unavailable to the user IIS APPPOOL\appIISPool SID (S-1-5-82-3351576649-1006875745-771203599-42452693-1279824824) from address LocalHost (Using LRPC) running in the application container Unavailable SID (Unavailable). This security permission can be modified using the Component Services administrative tool.

Судя по описанию ошибки: некий пользователь (например, IIS Apppool) или система (NT AUTHORITY\система) пытается запустить некий компонент COM с помощью инфраструктуры DCOM и не может этого сделать из-за отсутствия права «Локальный Запуск» или «Локальная активация» (Local Activation Permission). В коде ошибки содержатся только коды классов COM компонента и приложения. Попробуем определить, какому именно приложению принадлежит идентификатор и предоставить права, необходимые для его запуска.
Из описания события необходимо скопировать идентификаторы CLSID и APPID. В моем случае это
(в некоторых случаях идентификатор приложения может быть не указан — APPID Unavailable).
Также обратите внимание каких разрешений не хватает (Local Activation permission) и для какой учетной записи (NT AUTHORITY\SYSTEM или IIS APPPOOL\appIISPool SID — S-1-5-82-3351576649-1006875745-771203599-42452693-1279824824).
- Запустите редактор реестра (regedit.exe);
- Перейдите в ветку реестра, соответствующую вашему CLSID. У меня это HKEY_CLASSES_ROOT\CLSID\<000209FF-0000-0000-C000-000000000046>;

Если открыть консоль dcomcnfg до изменения разрешений на ветку реестра, все настройки на вкладке Security окажутся заблокированы (недоступны для изменения), несмотря на то, что вы запустили консоль от имени администратора.
Предыдущая статья Следующая статья



alt=»RDPConfig поддержка последних версий windows 10″ width=»58″ height=»56″ /> Разрешить несколько одновременных RDP сеансов в Windows 10 и 11
alt=»Ошибка загрузки Windows 8: The boot configuration data for your PC is missing or contains errors. File :\EFI\Microsoft\Boot\BCD Error code: 0xc000000f» width=»58″ height=»56″ /> Восстановление EFI загрузчика в Windows 10 и 11
alt=»Новые параметры mstsc в Windows 8.1″ width=»58″ height=»56″ />RDS Shadow – теневое подключение к RDP сеансам пользователей в Windows Server 2016/2019
Добрый день,
у меня каждый раз повторяется следующая проблема — к машине А подключен принтер (модель в данном случае значения не имеет), машина Б по сети имеет доступ к принтеру. После выключения — включения — перезагрузки принтер приходится переподключать…. Причем с первого раза это не удается , выдает «Ошибка сервера печати» и т.д… приходится несколько раз жать на Подключиться и только потом соединение устанавливается… И так каждый раз…. Системы на обеих машинах идентичны — 7ка Про…
Смотрите журналы системы на предмет ошибок, без этого что-то подсказать сложно.
Вопрос не имеет отношения к статье, лучше обсудить его на форуме.
У меня та же ошибка, только искомый ClassID находится здесь:
и отвечает за RuntimeBroker. Менять разрешения для этого элемента, давая группе администраторов полный доступ, стрёмно с точки зрения безопасности. Но я рискнул, однако в свойствах объекта DCOM на вкладке Безопасность ничего изменить нельзя. Как же быть?
У меня такая же ошибка для RuntimeBroker в W10. Свойства объекта закрыты от изменений. Предполагаю, что эта ошибка приводит к полному зависанию системы, когда прекращается реакция на любые действия мыши, клавиатуры, кнопки, и выводится только принудительным отключением питания
Попробуйте создать точку восстановления и дать себе права владельца на HKEY_CLASSES_ROOT\CLSID\
Евгений Анатольевич! у меня это и происходит.
Доброго времени суток!
Случилась такая печаль на windows server 2012 R2.
С тем отличием, что неизвестно APPID и неизвестно, какому компоненту DCOM не хватает прав.
Буду весьма благодарен за любую подсказку.
Параметры разрешений по умолчанию для компьютера не дают разрешения Локально Активация для приложения COM-сервера с CLSID <0006F03A-0000-0000-C000-000000000046>и APPID Недоступно пользователю DMN\prog с ИД безопасности S-1-5-21-3917816911-3051904071-4008862207-1232) и адресом LocalHost (с использованием LRPC), выполняемого в контейнере приложения Недоступно с ИД безопасности (Недоступно). Это разрешение безопасности можно изменить с помощью средства администрирования служб компонентов.
Вообще было бы неплохо после всех пертурбаций отобрать обратно права у админа и владельца вернуть
Localhost с использованием lrpc что это
Доброе время суток, уважаемые! Сразу после установки ОС в системном журнале Windows постоянно при каждой перезагрузке фигурирует вот эта непонятная ошибка:
Параметры разрешений для конкретного приложения не дают разрешения Локально Запуск для приложения COM-сервера с CLSID Windows.SecurityCenter.WscBrokerManager и APPID Недоступно пользователю NT AUTHORITY\СИСТЕМА с ИД безопасности (S-1-5-18) и адресом LocalHost (с использованием LRPC), выполняемого в контейнере приложения Недоступно с ИД безопасности (Недоступно). Это разрешение безопасности можно изменить с помощью средства администрирования служб компонентов.
Что это за ошибка?
- Изменено Александр Сметков 9 мая 2018 г. 17:01
Ответы
wsc это (Windows Security Center). Ошибка на рабоу системы не влияет и так как приоритет её низкий решения от MS вряд ли будет как и по многим другим ошибкам. Если мозолит глза — можно отключить логирование этого GUID в HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\WMI\Autologger\EventLog-System\<1b562e86-b7aa-4131-badc-b6f3a001407e>, Enabled поменять с 1 на 0 — ошибка не будет попадать в EventViewer. Вот здесь народ трёт эту тему tenforums.com
- Изменено smarty8 9 мая 2018 г. 17:15
- Помечено в качестве ответа Александр Сметков 9 мая 2018 г. 19:36
This posting is provided "AS IS" with no warranties, and confers no rights.
- Помечено в качестве ответа Александр Сметков 9 мая 2018 г. 19:36
Все ответы
wsc это (Windows Security Center). Ошибка на рабоу системы не влияет и так как приоритет её низкий решения от MS вряд ли будет как и по многим другим ошибкам. Если мозолит глза — можно отключить логирование этого GUID в HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\WMI\Autologger\EventLog-System\<1b562e86-b7aa-4131-badc-b6f3a001407e>, Enabled поменять с 1 на 0 — ошибка не будет попадать в EventViewer. Вот здесь народ трёт эту тему tenforums.com
- Изменено smarty8 9 мая 2018 г. 17:15
- Помечено в качестве ответа Александр Сметков 9 мая 2018 г. 19:36
В том то и дело, что глаза не мозолит, сдается мне из-за этого Sysprep нормально не работает, если интересно вот:
- Изменено Александр Сметков 9 мая 2018 г. 17:24
This posting is provided "AS IS" with no warranties, and confers no rights.
- Помечено в качестве ответа Александр Сметков 9 мая 2018 г. 19:36
Я менял разрешения как описано во множестве статей, ошибка не пропала, еще раз повторюсь, что эта ошибка возникает сразу же после установки ОС, то есть без какого либо внесения изменений.
Да вы правы на 1709 тоже есть эти ошибки хотя sysprep прекрасно работает, значит точно не из-за этого
- Изменено Александр Сметков 9 мая 2018 г. 19:35
Попробуй сделать проверку системы не только через sfc /scannow, а более строго через DISM с образцового виндового образа. Скачай MediaCreationTool1803 (кнопка Скачать средство сейчас) Когда утилита спросит — выбери создать .iso файл. После того как образ windows.iso скачается, примонтируй его. Там в disk :\sources\ лежит упакованый образцоваый образ install.esd в формате esd (Electronic Software Download).
Запусти PowerShell от админа, и сделай DISM /Online /Cleanup-Image /RestoreHealth /source:WIM: disk :\sources\install.esd:1 /LimitAccess
disk замени на букву диска куда ты положил windows.iso.
Мне не помогло. EventID 10016 "The application-specific permission settings do not grant Local Launch permission for the COM Server application with CLSID Windows.SecurityCenter.WscBrokerManager and APPID Unavailable
to the user NT AUTHORITY\SYSTEM SID (S-1-5-18) from address LocalHost (Using LRPC) running in the application container Unavailable SID (Unavailable). This security permission can be modified using the Component Services administrative tool." так и болтается.
Кроме того EventID 7024 "The DoSvc service terminated with the following service-specific error: General access denied error" тоже ни куда не делась.
Но может у тебя получится.